9.1 C
New York
Monday, March 4, 2024

Mozilla patches Firefox, Thunderbird towards zero-day exploited in assaults


Mozilla

Mozilla launched emergency safety updates immediately to repair a crucial zero-day vulnerability exploited within the wild, impacting its Firefox internet browser and Thunderbird e-mail consumer.

Tracked as CVE-2023-4863, the safety flaw is brought on by a heap buffer overflow within the WebP code library (libwebp), whose impression spans from crashes to arbitrary code execution.

“Opening a malicious WebP picture may result in a heap buffer overflow within the content material course of. We’re conscious of this problem being exploited in different merchandise within the wild,” Mozilla mentioned in an advisory printed on Tuesday.

Mozilla addressed the exploited zero-day in Firefox 117.0.1, Firefox ESR 115.2.1, Firefox ESR 102.15.1, Thunderbird 102.15.1, and Thunderbird 115.2.2.

Although particular particulars relating to the WebP flaw’s exploitation in assaults stay undisclosed, this crucial vulnerability is being abused in real-world eventualities.

Therefore, customers are strongly suggested to put in up to date variations of Firefox and Thunderbird to safeguard their techniques towards potential assaults.

Firefox 117.0.1

​As Mozilla revealed in immediately’s safety advisory, the CVE-2023-4863 zero-day additionally impacts different software program utilizing the susceptible WebP code library model.

One in all them is the Google Chrome internet browser, which was patched towards this flaw on Monday when Google warned that it is “conscious that an exploit for CVE-2023-4863 exists within the wild.”

The Chrome safety updates are rolling out to customers within the Secure and Prolonged secure channels and are anticipated to achieve your complete consumer base over the approaching days or even weeks.

Apple’s Safety Engineering and Structure (SEAR) group and The Citizen Lab on the College of Toronto’s Munk Faculty have been those who reported the bug on September sixth.

The safety researchers at Citizen Lab even have a historical past of figuring out and disclosing zero-day vulnerabilities continuously exploited in focused espionage campaigns led by government-affiliated menace actors.

These campaigns usually give attention to people at vital danger of assault, together with journalists, opposition politicians, and dissidents.

On Thursday, Apple additionally patched two zero-days tagged by Citizen Lab as exploited within the wild as a part of an exploit chain dubbed BLASTPASS to deploy NSO Group’s Pegasus mercenary spy ware onto absolutely patched iPhones.

Right this moment, the BLASTPASS patches have been additionally backported to older iPhone fashions, together with iPhone 6s fashions, the iPhone 7, and the primary era of iPhone SE.

Related Articles

LEAVE A REPLY

Please enter your comment!
Please enter your name here

Latest Articles